2016年11月25日金曜日

【備忘録】MAMP で WP-CLIコマンドを叩くと、「Error: APCu is not configured correctly.」とでちゃう!?

ちょっと引っかかったので備忘録としてメモ残しておきます。

wp-content/object-cache.php を削除せよ


サーバーの WordPress を MAMP へ落とし込む時に遭遇するかもしれません。
サーバー側の PHP が APCuモジュールを有効にして、かつ WordPress 側に 「APCu Object Cache Backend」をいれていた場合ですね。

このプラグインは
  • wp-content/object-cache.php 
に手動インストールするので忘れがちです。
MAMPを利用する場合には、このファイルを削除しておいてください。

2016年11月25日 @kimipooh

2 件のコメント:

  1. 間違ってます

    返信削除
  2. 実際にテストしてエラー(現在も MAMP 3.4 on PHP 7.0.10 の環境で再現する)でたので備忘録として載せています。お手数ですが、間違っているのであれば、是非説明をお願いします。なお wpコマンドを実行するにあたって利用する php は、 MAMP内部の phpへのPATHを通してつかっています。
    wp cli は 1.1.0です。
    % wp plugin list
    Error: APCu is not configured correctly. Please refer to https://wordpress.org/extend/plugins/apcu/installation/ for instructions.

    返信削除

Google+ Badge